Applies to: Application Server (all versions)
Symptom
The IDE will indicate the Platform as deployed, however, the Platform Manager will display the Platform as undeployed.
Alternatively, the IDE will indicate the Platform as undeployed, however, the Platform Manager will display the Platform as deployed.
Cause
Certain conditions (hardware failure of a deployed node, restoring a Galaxy from a backup, etc.) can cause the deployment state of an object in the IDE to be different from the object’s actual state.
Resolution
Follow the steps below to correct this mismatch.
Scenario 1 – Undeployed Objects Showing as Deployed
One potential cause for this scenario would be a hardware failure for a deployed node. When the hardware is replaced, the objects do not exist on the new computer, but the IDE still shows them as deployed.
Open the IDE. Select the object(s) currently in the mismatched state.
Right-click the object(s) and select Undeploy.
In the Undeploy window, check the ‘On failure mark as undeployed” checkbox and click OK.
The undeploy process will complete with failures for the mismatched objects, but the objects will now show as undeployed in the IDE.
Scenario 2 – Deployed Objects Showing as Undeployed
A potential cause for this scenario would be a Galaxy backup that was taken when objects were undeployed was used to restore the Galaxy while the object were deployed.
Open the IDE. Select the object(s) currently in the mismatched state.
- Right-click the object(s) and select Deploy. In the Deploy window, check the “Mark as Deployed” checkbox under “Deploy Status Mismatch” and click OK.
In the Deploy window, check the “Mark as Deployed” checkbox under “Deploy Status Mismatch” and click OK.
The deployment progress window will show the deployment fails for the mismatched objects, but they will now show as deployed in the IDE.